Вопрос по информатике:
47. дано целое четырехзначное положительное число n. составьте программу,которая определяет,какая из его цифр больше-вторая или последняя
48 дано целое четырехзначное положительное число n. составьте программу, которая определяет, кратно ли пяти произведение его цифр
- 14.08.2018 19:26
- Информатика
- remove_red_eye 4912
- thumb_up 81
Ответы и объяснения 1
var
n:integer;
begin
write('n = ');
readln(n);
if (n mod 10) > ((n div 100) mod 10) then
writeln('Последняя больше второй')
else
if (n mod 10) < ((n div 100) mod 10) then
writeln('Вторая больше последней')
else
writeln('Они равны');
readln;
end.
// Вторая программа
var
n, Pr:integer;
begin
write('n = ');
readln(n);
Pr := 1;
while n > 0 do
begin
Pr := Pr * (n mod 10);
n := n div 10;
end;
writeln('Pr = ', Pr);
if Pr mod 5 = 0 then
writeln('Кратно')
else
writeln('Некратно');
readln;
end.
- 15.08.2018 05:22
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.