Вопрос по информатике:
Составьте программу, которая считает в формуле, заданной с клавиатуры, количество плюсов и минусов. на паскале.
P.S формулы в программе быть не должно
- 12.04.2018 15:15
- Информатика
- remove_red_eye 9974
- thumb_up 67
Ответы и объяснения 1
var a:string;
i:integer;
c:boolean;
begin
readln(a);
repeat
if pos('+',a)0 then begin inc(i); delete(a,pos('+',a),1); end;
if pos('-',a)0 then begin inc(i); delete(a,pos('-',a),1); end;
if (pos('+',a)=0) and (pos('-',a)=0) then c:=true;
until c;
writeln(i);
end.
- 13.04.2018 02:38
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.