Вопрос по информатике:
1.Напишите программу, которая в последовательности натуральных чисел определяет количество всех чисел, кратных 3 и оканчивающихся на 0. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность).
2.Что будет на экране после выполнения программы
Var I, s,k: integer;
Begin .. s := 0;
for i := 0 to 10 do
s := s-i+5; writeln(s);
End.
- 03.04.2015 16:36
- Информатика
- remove_red_eye 18350
- thumb_up 19
Ответы и объяснения 1
var x,k:integer;
begin
k:=0;
repeat
readln(x);
if (x mod 10=0) and (x mod 3=0) then inc(k);
until x=0;
writeln(k-1);
end.
2) 0
s=0-0+5-1+5-2+5-3+5-4+5-5+5-6+5-7+5-8+5-9+5-10+5=0
- 04.04.2015 18:55
- thumb_up 7
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.