Вопрос по информатике:
Составить программу в которой записать в массив N номера положительных элементов массива (x1,x2...x15)
- 21.09.2018 09:28
- Информатика
- remove_red_eye 13534
- thumb_up 71
Ответы и объяснения 1
var
N: array [1..15] of 1..15; {Массив, в который записываются номера положительных элементов массива х}
x: array [1..15] of real; //Массив х
i: integer; //Переменная для цикла
Number: integer; //Сколько номеров было записано
begin
Number:= 0; //Обнуляем счетчик номеров
for i:= 1 to 15 do //Вводим с клавиатуры массив х
begin
writeln('Введите ', i, ' элемент массива х');
readln(x[i]);
if x[i] > 0 then {Если введенный элемент массива х положительный, то прибавляем к счетчику добавленных номеров 1 и присваиваем соответствующему элементу массива N номер элемента}
begin
Number:= Number + 1;
N[Number]:= i;
end;
end;
write('Номера положительных элементов массива х: ');
for i:= 1 to Number do write(n[i], ' '); //Выводим записанные номера элементов
writeln; {Переход на новую строку, чтобы при следующем запуске программы информация выводилась с новой строки}
end.
- 22.09.2018 15:43
- thumb_up 26
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.