Вопрос по информатике:
Cтроки. Паскаль.
1.Задано слово - последовательность произвольных символов. Сделать программу, в которой составляется слово перевертыш к данному ( символы записываются в обратной последовательности.)
2.Дана символьная строка. Слово - последовательность символов между пробелами, не содержащая пробелы внутри себя.составить программу, в которой выводились бы все слова, в которых есть заданный символ.
- 24.08.2018 09:20
- Информатика
- remove_red_eye 4473
- thumb_up 81
Ответы и объяснения 1
{Первая задача}
var
s, rez: string; // строки
i: integer; // целое число (счетчик)
begin
writeln('Введите строку:');
readln(s); //
for i := length(s) downto 1 do // просматриваем буквы, начиная с последней
rez := rez + s[i]; // прибавляем букву к результату
writeln(rez) // выводим результат
end.
- 25.08.2018 10:49
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.