Вопрос по информатике:
Написать программу Turpo pascal помогите пожалуйста что сможете!!!
Вывести на экран 6 раз свое имя. Составить блок-схему и написать программу вычисления суммы чисел от 6 до 10. Написать программу вычисления n! (факториал числа n), где n- целое неотрицательное число.Определение факториала:
0!=1, 1!=1, 2!=1*2, 3!=1*2*3, ……,n!=1*2*3*…*(n-1)*n.
Другими словами n!- это произведение n натуральных чисел.
- 10.10.2017 10:05
- Информатика
- remove_red_eye 8023
- thumb_up 66
Ответы и объяснения 1
1. вывести на экран 6 раз своё имя
program imya;
const n=6;
var i:integer;
begin
for i:=1 to n do
writeln('ваше имя');
end.
Пояснения: делала с помощью цикла (можно было написать и шесть раз writeln, но так удобнее). Переменную n ввела для быстрого изменения значений (если нужно будет написать имя не 6, а, к примеру, 8 раз, нужно было заменить только вначале). Ещё хочу отметить, что имя вводится по-английски и нельзя терять апострофы ( ' ).
2. program sum;
var sum:integer;
m:array[1..4] of integer;
i:integer;
begin
m[1]:=6
for i:=2 to 4 do begin
m[i]:=m[i-1]+1;
end;
sum:=m[1];
for i:=2 to 4 do begin
sum:=sum+m[i];
end;
writeln(sum);
end.
Пояснения: можно было делать и по-другому, но так тоже верно. Тут использовалось два цикла и массив. А блок-схему сами сделайте)))
3. program n!;
var n:real;
c:integer;
m:array[1..n] of integer;
begin
readln(n)
m[1]:=1;
for i:=2 to n do begin
m[i]:=m[i-1]+1;
end;
c:=m[1]
for i:=1 to n do begin
c:=c*m[i];
end;
writeln('n!',c);
end.
Если что не понятно, пишите, объясню
- 11.10.2017 15:34
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.