Вопрос по информатике:
Напишите программу, которая в последовательности натуральных чисел находит количество двухзначных чисел или сообщает, что таких чисел нет (выводит NO). Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести количество двухзначных чисел или вывести NO, если таких чисел нет.
- 09.05.2020 03:17
- Информатика
- remove_red_eye 250
- thumb_up 0
Ответы и объяснения 1
Ответ:
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 uses Crt,math; var l,n,x:longint; s:real; begin writeln('Введите последовательность 0-окончание ввода:'); writeln; repeat x:=l; readln(l); t:=t+1; if (l>99) and (l<1000) then begin n:=n+1; s:=s+l; end; until l=0; gotoxy(round(log10(x+1))+3,wherey-2); if n=0 then write('=NO') else write('=',s/n:0:4); readln; end.- 11.05.2020 07:32
- thumb_up 0
Знаете ответ? Поделитесь им!
Как написать хороший ответ?
Чтобы добавить хороший ответ необходимо:
- Отвечать достоверно на те вопросы, на которые знаете правильный ответ;
- Писать подробно, чтобы ответ был исчерпывающий и не побуждал на дополнительные вопросы к нему;
- Писать без грамматических, орфографических и пунктуационных ошибок.
Этого делать не стоит:
- Копировать ответы со сторонних ресурсов. Хорошо ценятся уникальные и личные объяснения;
- Отвечать не по сути: «Подумай сам(а)», «Легкотня», «Не знаю» и так далее;
- Использовать мат - это неуважительно по отношению к пользователям;
- Писать в ВЕРХНЕМ РЕГИСТРЕ.
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.