Вопрос по информатике:
Дан массив из 10 элементов. Необходимо заполнить его первыми 10 членами арифметической прогрессии с заданными первым членом прогрессии a и её разностью p.
Формат входных данных
С клавиатуры вводятся целые числа a и p (−100≤a,p≤100−100≤a,p≤100).
Формат выходных данных
Требуется вывести содержимое массива после заполнения согласно условию задачи. Элементы должны разделяться пробелами.
- 07.08.2016 00:36
- Информатика
- remove_red_eye 6408
- thumb_up 36
Ответы и объяснения 1
Const
n=10;
var
m:array[1..n] of integer;
a,p,i:integer;
begin
Write('Введите a,p: ');
Read(a,p);
for i:=1 to n do
begin
m[i]:=a+p*(i-1);
Write(m[i],' ')
end;
Writeln;
end.
Тестовое решение
Введите a,p: -5 8
-5 3 11 19 27 35 43 51 59 67
- 07.08.2016 14:12
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.