Вопрос по информатике:
На языке программирования Pascal составить программу, которая проверяет, является ли введенное с клавиатуры число простым или нет (т. е. число делится только на 1 и на само себя без остатка) (число 354)
- 23.01.2018 06:13
- Информатика
- remove_red_eye 11765
- thumb_up 25
Ответы и объяснения 1
function isPrime(n:integer):boolean;
var res:boolean;
i:integer;
begin
if n>1 then res:=true
else res:=false;
for i:=2 to n div 2 do
if n mod i = 0 then
begin
res:=false;
break;
end;
isPrime:=res;
end;
var n:integer;
begin
writeln('введите целое число: n = ');
readln(n);
write(isPrime(n));
readln;
end.
- 24.01.2018 18:04
- thumb_up 24
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.