Вопрос по информатике:
Написать программу на Pascal, либо C++ и составить блок-схему
Даны натуральные числа A1,A2... Признак конца последовательности 99. Найти количество положительных чисел и удвоенное количество отрицательных чисел.
- 20.10.2017 05:52
- Информатика
- remove_red_eye 18967
- thumb_up 25
Ответы и объяснения 1
Подключи библиотеки iostream и Windows.h
int main() {
int nNumsCount = 0,
pNumsCount;
int number = 0;
while(std::cin >> number && number != 99){
if(number < 0)
++nNumsCount;
if(number > 0)
++pNumsCount;
}
std::cout << pNumsCount << '\n' << 2*nNumsCount << std::endl;
system("pause");
return 0;
}
- 21.10.2017 10:28
- thumb_up 52
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.