Вопрос по информатике:
Паскаль, срочно
Напишите программу, которая определяет правильность записи целого числа в восьмеричной системе счисления.
Формат входных данных
На вход программы поступает символьная строка.
Формат выходных данных
Программа должна вывести ответ 'YES', если строка представляет собой правильную запись целого числа в восьмеричной системе счисления, и 'NO', если запись ошибочна.
Примеры
входные данные выходные данные
12345
YES
- 07.05.2017 02:27
- Информатика
- remove_red_eye 2970
- thumb_up 27
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString;
if s.MatchValue('[0-7]*')=s then Writeln('YES')
else Writeln('NO')
end.
- 08.05.2017 09:25
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.