Вопрос по информатике:
Написать программу, которая запрашивает реальный рост и вес пользователя, вычисляет его оптимальный вес, сравнивает его с реальным и выдает рекомендацию о необходимости поправиться или похудеть. Pascal ABC
- 14.10.2016 14:59
- Информатика
- remove_red_eye 1837
- thumb_up 35
Ответы и объяснения 1
p,h,imt:real;
begin
Write('Введите вес в кг и рост в см: ');
Read(p,h);
imt:=p/Sqr(h/100);
if imt<=16 then Writeln('Дефицит массы тела. Необходимо поправиться.')
else if imt<25 then Writeln('Нормальный вес! Так держать!')
else if imt<=30 then Writeln('Избыточная масса тела. Нужно худеть.')
else if imt<=35 then Writeln('Ожирение 1-й степени. Необходимо похудеть.')
else if imt<=45 then Writeln('Ожирение 2-й степени. Срочно худейте!')
else Writeln('Ожирение 3-й степени. Немедленно начинайте худеть!!!')
end.
- 15.10.2016 01:14
- thumb_up 49
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.