Вопрос по информатике:
Помогите на языке Cи
1. Введите с клавиатуры год в интервале от 1 до 2200 включительно,
выведите LEAP, если он високосный, или NORMAL, если нет. Выведите
ERROR, если номер года больше 2200 или меньше 1.
2. Напишите программу, которая вводит с клавиатуры один символ, ивыводит DIGIT, этот символ является цифрой, CAPITAL — если за-
главной латинской буквой, LOWERCASE — если строчной, и выводит NON-ALPHANUMERIC в противном случае.
- 04.09.2017 19:51
- Информатика
- remove_red_eye 7298
- thumb_up 25
Ответы и объяснения 1
using namespace std;
int main()
{
int a;
cin >> a;
if (a 2200)
{
cout << "ERROR";
return 0;
}
if (a % 400 == 0 || (a % 4 == 0 && a % 100 != 0))
{
cout << "LEAP";
return 0;
}
else
{
cout << "NORMAL";
return 0;
}
}
- 05.09.2017 05:39
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.