Вопрос по информатике:
Помогите:
Практическая работа №3. Ветвления
Уровень A. Напишите программу, которая получает с клавиатуры два целых числа и находит наибольшее и наименьшее из них.
Пример:
Введите два числа: 1 5
Наименьшее число 1
Наибольшее число 5
Уровень B. Напишите программу, которая получает с клавиатуры четыре целых числа и находит наибольшее из них.
Пример:
Введите четыре числа: 1 2 5 3
Наибольшее число 5
Уровень C. Напишите программу, которая получает с клавиатуры возрасты трёх человек (Антона, Бориса и Виктора) и определяет, кто из них старше.
Пример:
Возраст Антона: 15
Возраст Бориса: 17
Возраст Виктора: 16
Ответ: Борис старше всех.
Пример:
Возраст Антона: 17
Возраст Бориса: 17
Возраст Виктора: 16
Ответ: Антон и Борис старше Виктора.
На языке паскаль.
- 02.02.2018 13:00
- Информатика
- remove_red_eye 14449
- thumb_up 48
Ответы и объяснения 1
var a,b:integer;
begin
writeln ('Введите 2 числа');
readln (a,b);
if a=b then writeln ('Числа одинаковые')
else if a>b then
begin writeln ('Наибольшее число ',a);
writeln ('Наименьшее число ',b);
end
else begin writeln ('Наибольшее число ',b);
writeln ('Наиментшее число 10 ',a);
end;
end.
program p2;
var a,b,c,d:integer;
begin
writeln ('Введите 4 числа');
readln (a,b,c,d);
if aif c
end.
program p3;
var a,b,v:integer;
begin
writeln ('Введите возрасты людей:');
write ('Антона - ');
readln (a);
write ('Бориса - ');
readln (b);
write ('Виктора - ');
readln (v);
if (a=b) and (a=v) then writeln ('Все люди одного возраста');
if (a=b) and (a>v) then writeln ('Антон и Борис старше Виктора');
if (a=b) and (a
if (b=v) and (b>a) then writeln ('Борис и Виктор старше Антона');
if (b=v) and (belse if (a>v) and (a>b) then writeln ('Антон старше всех');
if (a=v) and (a>b) then writeln ('Антон и Виктор старше Бориса');
if (a=v) and (aelse if (b>v) and (b>a) then writeln ('Борис старше всех');
end.
- 03.02.2018 12:29
- thumb_up 50
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.