Вопрос по информатике:
Составьте программу вычисления суммы всех двузначных чисел, имеющих в своем составе цифру 1 или 3. ( программа для Паскаля, 9 класс и function не проходили, поэтому как можно проще и я так думаю с var или тому подобное) очень нужно
- 23.05.2018 18:38
- Информатика
- remove_red_eye 10171
- thumb_up 32
Ответы и объяснения 1
Var s,i:integer;
begin
s:=0;
for i:=10 to 93 do
begin
if (i mod 10 = 1) or (i div 10 = 1) or (i mod 10 = 3) or (i div 10 = 3) then
s:=s+i;
end;
writeln('Сумма всех двузначных чисел, имеющих в составе 3 или 1 равна ', s)
end.
- 24.05.2018 03:35
- thumb_up 9
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.