Вопрос по информатике:
Составить программу, используя оператор REPEAT. Вводятся числа до тех пор пока не введется 0. Определить, сколько среди них положительных (включая 0) и сколько отрицательных. (Числа вводятся в одну переменную в цикле).
- 10.01.2018 23:06
- Информатика
- remove_red_eye 12641
- thumb_up 24
Ответы и объяснения 1
Program M;
var i : integer = 0;
pologitelnie : integer = 0;
otricatelnie : integer = 0; a : array[0..100] of Integer;
begin
repeat
begin
read (a[i]);
if (a[i]>=0) then
pologitelnie := pologitelnie + 1
else
otricatelnie := otricatelnie + 1;
i := i + 1;
end;
until a[i-1] = 0;
writeln('положительных: ', pologitelnie);
writeln('отрицательных: ', otricatelnie);
end.
- 11.01.2018 17:30
- thumb_up 49
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.