Вопрос по информатике:
Напишите программу, которая в последовательности целых чисел определяет их сумму и количество четных чисел. Программа получает на вход целые числа, количество введенных чисел неизвестно, последователньость чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность)
Количество чисел не превышает 1000. Введенные числа по модулю не превышают 30 000.
Программа должна вывести два числа: сумму последовательности и количество четных чисел, кратных 5.
Пример работы программы:
Входные данные:
4
60
15
0
Выходные данные:
79
1
- 03.04.2018 11:42
- Информатика
- remove_red_eye 7522
- thumb_up 32
Ответы и объяснения 1
Внимание! Если программа не работает, обновите версию!
begin
var (s,k):=(0,0);
ReadSeqIntegerWhile(t->t0)
.ForEach(t->begin s+=t; if t mod 10=0 then k+=1 end);
Writeln(s,NewLine,k)
end.
- 04.04.2018 02:46
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.