Вопрос по информатике:
Дано натуральное число N (N<10). Написать программу, для вычисления суммы вида 0,1+0,2+0,3+… (N слагаемых).
ИСПОЛЬЗОВАТЬ ЦИКЛ FOR!!
- 21.03.2018 19:23
- Информатика
- remove_red_eye 16864
- thumb_up 31
Ответы и объяснения 2
//необходимо инициализировать переменную N
double sum = 0;
for(int i=1; i<=N; i++)
sum += 0.1 * i;
//результат в переменной sum
- 22.03.2018 09:44
- thumb_up 49
Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('n=');
var s:=0.0;
for var i:=1 to n do s+=1/i;
Writeln('S=',s)
end.
Пример
n= 10
S=2.92896825396825
- 23.03.2018 01:47
- thumb_up 13
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.