Вопрос по информатике:
Составьте программу, которая позволяет ввести элементы массива а [1...10] с клавиатуры и выводит на экран количество отрицательных элементов и их индексы.
- 22.12.2016 06:39
- Информатика
- remove_red_eye 3097
- thumb_up 23
Ответы и объяснения 2
Var a:array[1..10] of integer;
b:array[1..10] of integer;
i,k:integer;
begin
for i:=1 to 10 do
begin;
readln(a[i]);
if a[i]<0 then
begin;
k+=1;
b[k]:=i;
end;
end;
writeln('Индексы отрицательных');
for i:=1 to k do
writeln(b[i]);
writeln('Всего:',k);
end.
- 23.12.2016 23:24
- thumb_up 35
Var a:array [1..10] of integer;
i,k:integer;
begin
for i:=1 to 10 do
begin
read(a[i]);
if a[i]<0 then inc(k);
end;
writeln('кол-во элементов:',k);
writeln('их индексы:');
for i:=1 to 10 do
if a[i]<0 then write(i,' ');
end.
- 24.12.2016 03:20
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.