Вопрос по информатике:
СРОЧНО!!!!!!!!!!
Написать программу в Паскаль
1) Дано n число, верно ли, что сумма его цифр четное число
2) Найдите сумму его цифр больше 5
СРОЧНО!!!!!!!!!
- 10.04.2018 19:11
- Информатика
- remove_red_eye 16415
- thumb_up 33
Ответы и объяснения 1
var n,a:integer;
begin
a:=0;
WriteLn(n);
while n>0 do
begin
a:=a + (n mod 10);
n:=n div 10;
end;
end.
Вторая
var n,a:integer;
begin
a:=0;
WriteLn(n);
while n>0 do
begin
if n mod 10>5 then
begin
a:=a + (n mod 10);
end;
n:=n div 10;
end;
end.
- 11.04.2018 19:04
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.