Вопрос по информатике:
Напишите программу, которая в последовательности целых чисел определяет их сумму и подсчитывает разность количестваположительных и отрицательных чисел последовательности. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). программа должна вывести два числа: сумму чисел и разность количества положительных и отрицательных чисел.
- 04.06.2015 10:33
- Информатика
- remove_red_eye 18506
- thumb_up 35
Ответы и объяснения 1
var sum,kp,ko,a: integer;
begin
readln(a);
sum:=0;
ko:=0;
kp:=0;
while a0 do
begin
sum:=sum+a;
if a>0 then kp:=kp+1
else ko:=ko+1;
readln(a);
end;
writeln(sum);
writeln(kp-ko);
end.
- 05.06.2015 04:06
- thumb_up 44
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.