Вопрос по информатике:
Дано натуральное число n (где n больше или равно нулю). Вычислить: z=2*5*8...*(3n-1). Нужно написать программу в Паскале вида program-var-begin-writeln-write-read-end и т.д. и т.п.
- 07.02.2018 14:20
- Информатика
- remove_red_eye 7038
- thumb_up 29
Ответы и объяснения 1
n, i, z: Integer;
begin
Write('n=');
ReadLn(n);
if n = 0 then
WriteLn('z=-1')
else if (n < 0) then
WriteLn('Введено отрицательное число')
else
begin
z := 1;
for i := 1 to n do
z := z * 1 * (3 * i - 1);
WriteLn('z=', z);
end;
end.
- 08.02.2018 09:06
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.