Вопрос по информатике:
1. Дана строка, содержащая текст. Сколько слов в тексте? Сколько цифр в тексте?
2. Опишите содержимое текстового файла, из которого будут вводиться данные, соответствующие описанию из предыдущего задания, для нескольких учеников класса (не менее 5).
- 17.11.2017 15:44
- Информатика
- remove_red_eye 9225
- thumb_up 49
Ответы и объяснения 1
Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString;
Writeln('Количество слов в строке равно ',s.ToWords.Count);
Writeln('количество цифр в строке равно ',
s.Where(c->c in ['0'..'9']).Count)
end.
Пример
В России День Победы празднуется 9 мая начиная от 1945 года
Количество слов в строке равно 11
количество цифр в строке равно 5
2. Текстовый файл может содержать столько текстовых строк, сколько в классе учеников. Каждый ученик должен прочитать и обработать строку из файла, соответствующую своему порядковому номеру в журнале.
- 18.11.2017 12:57
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.