Вопрос по информатике:
Составьте программу которая находит сумму цифр трех значного числа на PascalABC
- 04.03.2015 17:16
- Информатика
- remove_red_eye 11297
- thumb_up 18
Ответы и объяснения 2
i,n,s: Integer;
begin
write('Введите трехзначное число ');
read(n);
i:=0;
while (n0) Do
begin
s :=n Mod 10;
i:=i+s;
n:= n Div 10;
end;
writeLn('Сумма цифр : ',i)
end.
- 05.03.2015 07:40
- thumb_up 39
var a: integer;
begin
readln(a);
a:=abs(a);
write((a div 100)+ (a mod 10)+ (a mod 100 div 10));
end.
- 06.03.2015 08:23
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.