Вопрос по информатике:
1.Написать программу, которая определяет наибольшее отрицательное целое число в массиве из 10 элементов.
Значения элементов массива вводятся пользователем.
2.Написать программу, которая определяет наибольшее по модулю число в массиве из 10 введенных пользователем чисел.
- 10.02.2018 17:16
- Информатика
- remove_red_eye 13452
- thumb_up 30
Ответы и объяснения 1
var
mas: array[0..10] of Integer ;
i,min,j: Integer;
begin
min:=0;
writeln('Введите числа:');
for i := 1 to 10 do begin
ReadLn(mas[i]);
if (mas[i] <0)
then j:=mas[i];
if j then min:=j;
end;
WriteLn('Минимальное отрицательное число:',min);
end.
2.
var
mas: array [0..10] of Integer;
i, max, j: Integer;
begin
writeln('Введите числа:');
for i := 1 to 10 do
begin
ReadLn(mas[i]);
if abs(mas[i - 1]) < abs(mas[i]) then
max := mas[i] ;
end;
WriteLn('Наибольшее по модулю число:', max);
end.
- 11.02.2018 11:06
- thumb_up 11
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.