Вопрос по информатике:
Помогите!!!!!
Помогите решить!!!
1) Какие из описаний могут быть именами переменных
a) 4_с
b) sum
c) b 3
d) one_а
2) Какая команда в Pascal-е служит для того, чтобы задать какой-либо переменной значение до выполнения алгоритма? Приведите пример.
3) Найдите и исправьте ошибки в следующей программе:
program prim_a;
var m, n, k: integer;
writeln('введите значения переменных m и n');
red(m,n, k);
writeln(m+n+k);
end.
4) Напишите программу для решения одной из двух задач:
a) Найти площадь и периметр прямоугольника со сторонами а и b.
b) Найти значение выражения:
5) Напишите программу для нахождения суммы крайних цифр трехзначного числа.
- 03.02.2017 14:00
- Информатика
- remove_red_eye 19787
- thumb_up 45
Ответы и объяснения 1
1)
a) не может, потому что переменные должны всегда начинаться с буквы
b) может
c) не может, слова могут быть разделены только знаком "_",не пробелом!
d) может
2) присваивание, обозначается знаком "="
Например:
sum = 0;
3)
4 строка - не red, а read
пропущена трока между 2 и 3 строчкой - это begin
4)
var
S, P, a, b: integer
begin
write('Введите сторону а: ');
readln(a);
write('Введите сторону b: ');
readln(b);
S = a * b; {нахидим площадь}
P = (a + b) * 2; {находим периметр}
writeln('Площадь = ', S, ', периметр = ', P);
end.
5)
Var
number, {Трехзначное число}
num1, {Первая крайняя цифра}
num2, {Вотрая крайняя цифра}
: integer;
Begin
write('Введите число');
readln(number);
num1 = number mod 10;
num2 = number div 100;
writeln('Сумма крайних цифр числа ', number, ' = ', num1 + num2);
End.
- 04.02.2017 16:33
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.