Вопрос по информатике:
Напишите программу, которая в последовательности целых чисел определяет максимальное чётное число. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность). Гарантируется, что, хотя бы одно чётное число в последовательности есть.
Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000.
Программа должна вывести одно число: максимальное чётное число.
- 24.08.2017 22:08
- Информатика
- remove_red_eye 16293
- thumb_up 13
Ответы и объяснения 1
//Pascal ABC.NET v3.1 сборка 1219
Var
x,max:integer;
begin
max:=-2147483648;
readln(x);
while x0 do
begin
if (max
end;
if max=-2147483648 then writeln('Nothing') else writeln(max);
end.
Пример ввода:
1
2
6
4
0
Пример вывода:
6
- 25.08.2017 00:29
- thumb_up 11
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.