Вопрос по информатике:
Составить программу, которая для любого натурального числа печатает на естественном языке количество цифр в записи этого числа.Составить программу на Паскале.Срооооочно!!!
- 07.07.2018 13:38
- Информатика
- remove_red_eye 7697
- thumb_up 40
Ответы и объяснения 2
a:real;
begin
WriteLn('Введите чтсло');
readln(a);
Write('В записи этого числа ');
case a of
1..9 : Write ('одна цифра');
10..99 : Write ('две цифры');
100..999 : Write ('три цифры');
1000..9999 : Write ('четыре цифр');
10000..99999 : Write ('пять цифр');
100000..999999 : Write ('шесть цифр');
else Writeln('Данное число слишком велико');
end;
end.
- 08.07.2018 01:45
- thumb_up 46
k:Integer;
begin
write ('Введите число: ');
readln (a);
repeat
k:=k+1;
a:=a div 10
until a=0;
writeln('Количество цифр: ',k)
end.
var a:string;
begin
write ('Введите число: ');
readln (a);
writeln('Количество цифр: ',Length(a))
end.
- 09.07.2018 23:00
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.