Вопрос по информатике:
Помогите, пожалуйста! Через паскаль! Тема: «Поиск наибольшего или наименьшего элемента массива»
Написать программу, которая запрашивает у пользователя строку и заменяет в ней все пробелы знаками подчеркивания '_'
Не использовать: const, count и другие, которые не по теме!
- 24.08.2018 21:39
- Информатика
- remove_red_eye 7444
- thumb_up 42
Ответы и объяснения 2
s: String;
begin
writeln('Введите текст');
readln(s);
for i:=1 to Length(s) do
begin
if s[i]=' ' then s[i]:='_';
end;
writeln(s);
end.
- 25.08.2018 12:39
- thumb_up 17
g: string;
i: byte;
begin
readln(g);
i := 1;
while g[i] = ' ' do delete(g,i,1);
i := length(g);
while g[i] = ' ' do begin delete(g,i,1); i := i - 1 end;
i := 1;
while i <= length(g) do begin
if g[i] = ' ' then
if g[i-1] = '*' then begin
delete(g,i,1);
i := i - 1;
end
else begin
delete(g,i,1);
insert('_',g,i);
end;
inc(i);
end;
writeln(g);
end.
- 26.08.2018 19:08
- thumb_up 46
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.