Вопрос по информатике:
Помогите пожалуйста с домашней работой.
Напишите программу, которая вычисляет сумму:
а) первых n натуральных чисел;
Решение тремя способами(while, repeat,for.)
- 24.10.2017 15:10
- Информатика
- remove_red_eye 11877
- thumb_up 26
Ответы и объяснения 1
function getSumWhile(n:integer):integer;var sum, i:integer;begin sum := 0; i := 1; while i <= n do begin sum := sum + i; i := i + 1; end; result := sum;end;
function getSumRepeat(n:integer):integer;var sum, i:integer;begin i := 1; sum := 0; repeat sum := sum + i; i := i + 1; until i > n; result := sum;end;
begin writeln(getSumFor(1)); writeln(getSumWhile(1)); writeln(getSumRepeat(1));end.
- 25.10.2017 12:34
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.