Вопрос по информатике:
Написать программу решения следующей задачи: Определить периметры
трѐх треугольников, если заданы координаты их вершин. Использовать
подпрограмму-функцию
- 18.07.2016 15:58
- Информатика
- remove_red_eye 8466
- thumb_up 46
Ответы и объяснения 1
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 uses crt; var i,xa,ya,xb,yb,xc,yc: integer; function Dlina(x1,y1,x2,y2: integer):real; var d: real; begin d:= sqrt(sqr(y1-y2)+sqr(x1-x2)); Dlina:=d; end; function Perimetr(a,b,c: real): real; begin Perimetr:=a+b+c; end; procedure Vvod (nt: byte; var ax,ay,bx,by,cx,cy: integer); begin writeln ('Координаты вершины A ',nt,' треугольника'); readln (ax,ay); writeln ('Координаты вершины B ',nt,' треугольника'); readln (bx,by); writeln ('Координаты вершины C ',nt,' треугольника'); readln (cx,cy); end; begin for i:=1 to 3 do begin Vvod (i,xa,ya,xb,yb,xc,yc); writeln ('Периметр ',i,' треугольника = ',Perimetr(Dlina(xa,ya,xb,yb),Dlina(xb,yb,xc,yc),Dlina(xc,yc,xa,ya)):0:2); writeln; end; readkey end.
- 19.07.2016 12:24
- thumb_up 43
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.