Вопрос по информатике:
Дано четыре числа - длины ребер параллелепипеда и радиус шара. Определить, можно ли шар поместить в параллелепипед.
Входные данные:Во входном потоке задано четыре вещественных числа - длины ребер параллелепипеда и радиус шара соответственно. Значение всех исходных величин не превышает 30000.
Выходные данные:В выходной поток вывести 'YES' или 'NO'.
- 24.09.2017 18:35
- Информатика
- remove_red_eye 7300
- thumb_up 34
Ответы и объяснения 1
PascalABC.NET 3.3.5, сборка 1660 от 20.04.2018
Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadlnString.ToReals;
if a.Take(3).Min>2*a[3] then Writeln('YES') else Writeln('NO');
end.
Если нужны именно файлы:
begin
var a:=ReadAllText('input.txt').ToReals;
var s:=a.Take(3).Min>2*a[3] ? 'YES' : 'NO';
WriteAllText('output.txt',s)
end.
- 25.09.2017 06:25
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.