Вопрос по информатике:
РЕБЯТА ВЫРУЧАЙТЕ, помогите пожалуйста написать программу в паскале: " Даны два целых числа: D (день) и M (месяц), определяющие правильную дату не високосного года. Вывести значения D и M для даты, предшествующей указанной."
ИСПОЛЬЗУЯ КОМАНДУ CASE.
- 23.09.2015 17:14
- Информатика
- remove_red_eye 18820
- thumb_up 34
Ответы и объяснения 1
Program a;
var D,M: integer;
begin
readln (D,M); //DD MM
if (D1) then Writeln (D-1,' ',M)
else
case M of
01 : Writeln('31 12');
02 : Writeln('31 01');
03 : Writeln('28 02');
04 : Writeln('31 03');
05 : Writeln('30 04');
06 : Writeln('31 05');
07 : Writeln('30 06');
08 : Writeln('31 07');
09 : Writeln('31 08');
10 : Writeln('30 09');
11 : Writeln('31 10');
12 : Writeln('30 11');
end;
end.
- 24.09.2015 02:47
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.