Вопрос по информатике:
Напишите программу, которая заменяет во всей строке одну последовательность символов на другую.
Пример:
Введите строку:
(X > 0) and (Y < X) and (Z > Y) and (Z <> 5)
Что меняем: and
Чем заменить: &
Результат
(X > 0) & (Y < X) & (Z > Y) & (Z <> 5)
- 15.02.2018 05:47
- Информатика
- remove_red_eye 6469
- thumb_up 10
Ответы и объяснения 1
Внимание! Если программа не работает, обновите версию!
begin
var s:string; Writeln('Введите строку:'); Readln(s);
var s1:=ReadlnString('Что меняем:');
var s2:=ReadlnString('Чем заменить:');
s:=s.Replace(s1,s2);
Writeln('Результат'); Writeln(s)
end.
Пример
Введите строку:
(X > 0) and (Y Y) and (Z 5)
Что меняем: and
Чем заменить: &
Результат
(X > 0) & (Y Y) & (Z 5)
- 16.02.2018 15:03
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.