Вопрос по информатике:
Вася очень любит собирать грибы. Набрав полную корзинку, он вышел на дорогу и теперь хочет понять, где находится ближайшая остановка автобуса. Вдоль дороги стоят километровые столбы (начиная с нулевого километра), а возле каждого K-го километрового столба расположена остановка. Например, при K=3, остановки расположены у километровых столбов 0, 3, 6, 9, ... . В данный момент Вася находится рядом с километровым столбом P. Выясните, возле какого километрового столба расположена ближайшая остановка. Формат входных данных В первой строке задано число K (1 ≤ K ≤ 2 * 109). Во второй строке задано число P (1 ≤ P ≤ 2 * 109). Формат результата Выведите возле какого километрового столба расположена ближайшая к Васе остановка. Если правильных ответов несколько - выведите любой из них.
- 19.08.2015 23:58
- Информатика
- remove_red_eye 2081
- thumb_up 44
Ответы и объяснения 1
begin
readln(k);
readln(p);
n:=p div k * k;
if (p mod k) <= (k-p mod k) then writeln(n)
else writeln(n+k);
end.
Пример:
4
15
16
- 20.08.2015 07:42
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.