Вопрос по информатике:
ПОМОГИТЕ ЗАДАЧУ В ПАСКАЛЕ РЕШИТЬ!
Количество чисел не превышает 1000. Введенные числа по модулю не превышают 30000 программа должна вывести два числа: сумму чисел и разность количества положительных и отрицательных чисел. Пример работы программы:
Входные данные:150;-200;-1;0
Выходные данные:-51;-1
- 02.06.2018 08:09
- Информатика
- remove_red_eye 6802
- thumb_up 7
Ответы и объяснения 1
program HelloWorld;var i, x, y, z: integer;begin
i:=1;while i0 do begin readln(i); x:=x+i; if i>0 then y:=y+1; if i<0 z:=z+1 end;writeln(x, ';', y-z); end.
- 03.06.2018 04:10
- thumb_up 50
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.