Вопрос по информатике:
Определите сколько существует натуральных чисел, таких, что выполняются следующие условия:
1. Искомые числа не должны превосходить данного N.
2. Искомые числа должны делиться на данные числа a и b и не должны делиться на данное c (числа a, b и c - попарно взаимно простые). На паскале плиз
- 10.04.2015 03:18
- Информатика
- remove_red_eye 1611
- thumb_up 19
Ответы и объяснения 1
- если число делится на a и b, оно делится на a×b;
- если число не превышает N, то m×a×b, где m=1,2,3... также не превышает N;
- если при этом число не делится на с, то a×b также не делится на с.
Следовательно, количество чисел, не превышающих N равно N div (a×b), где div - операция деления нацело.
Из этого количества нужно вычесть количество чисел, делящихся на c, т.е. N div (a×b×c)
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('N=');
var (a,b,c):=ReadInteger3('Введите через пробел a,b,c:');
Writeln(n div (a*b) - n div (a*b*c))
end.
- 11.04.2015 18:18
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.