Вопрос по информатике:
1. какое значение не может принимать переменная х если она объявлена таким образом:
var x:integer
1. 5
2. 12000
3. 8,6
4. 30246
2. какое значение будет иметь переменная а после выполнения следующего кода:
a:=4;
b:=2;
a:=a*a*b;
b:=a+b;
1. 32
2. 34
3. 18
4. 16
3. какой операнд пропущен в следующем отрывке кода
a:=7;
b:=3;
a>b*2 then f:=0;
writeln(f);
else
while
case
if
4. Определите тип данных следующего числа 2.3?
5. Чему равно значение выражения: (1234 div 10) mod 2?
1. 1
2. 3
3. 4
4. 2
6. Чему равно значение выражения: sqrt(16)*2-sqr(3)-20/5
1. -5
2. -6
3. 5
4. 6
7. Какое значение примет переменная М после выполнения следующих действий: М:=2*5+12/(2+4)-sqr(2)?
1. 16
2. 10
3. 3
4. 6
8. Необходимо вывести числа от -3 до 7.
1. random(7)
2. random(6)
3. random(11)-3
4. random(10)-3
5. random(7)-3
9. Определите значение переменной С после выполнения фрагмента программы. а:=100; в:=30; а:=а-в*3; If а>в then c:=а-в else c:=a-в
1. 180
2. 20
3. 70
4. -20
10. Из какого диапазона будут выдаваться числа в программе: a:=random(11)-5
1. [-5,11]
2. [-5,10]
3. [-5,5]
4. [-5,6]
11. Какая команда означает описание переменных?
1. Program
2. var
3. begin
4. writeln
5. readln
12. Для того чтобы ввести числа с клавиатуры необходимо использовать команду?
1. writeln
2. readln
3. random
4. case
13. В программе необходимы числа из диапазона [1,12]. Как можно задать данные числа?
1. random(12)+1
2. random(13)+1
3. random(12)-1
4. random(13)-1
14. Чему будет равно значение переменной К после выполнения следующих действий? K:=10; S:=K+K+5; K:=S; S:=k-10;
1. 10
2. 5
3. 25
4. 15
15. Какое значение примет переменная G после выполнения действия G:=48/2+4?
1. 24
2. 28
3. 8
4. 2
16. Какое значение примет переменная М после выполенния действия М:=20/10+10*(sqr(4)/2)?
1. 80
2. 41
3. 82
4. 40
17. Из какого диапазона будут числа в программе при записи: D:=random(16)+10
1. [10,16]
2. [10,15]
3. [10,25]
4. [10,26]
18. Задержка экрана:
1. else
2. writeln
3. end
4. readln
19. Определите тип переменной х, если х:=а/в, где а и в переменные целого типа
1. строковый
2. символьный
3. вещественный
4. целый
- 01.07.2015 12:41
- Информатика
- remove_red_eye 10661
- thumb_up 43
Ответы и объяснения 1
2. 2
3. if (номер 5)
4. real
5. 1
6. 1
7. 4 (правильный ответ - 8, но такого варианта нету)
8. 3
9. 4
10. 3
11. 2
12. 2
13. 1
14. 3
15. 2
16. 3
17. 3
18. 4
19. 4
- 02.07.2015 21:44
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.