Вопрос по информатике:
C++. СРОЧНО составьте программу, где вводят 4-значное натуральное число и переставляет его первую и последнюю цифру. Например, 3456 должно получиться 6453
- 14.04.2015 07:35
- Информатика
- remove_red_eye 17388
- thumb_up 50
Ответы и объяснения 1
using namespace std;
int main() {
int n;
cin >> n;
int a = n % 10, b = (n / 10) % 10, c = (n / 100) % 10, d = n / 1000;
cout << a * 1000 + c * 100 + b * 10 + d;
}
- 15.04.2015 17:23
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.