Вопрос по информатике:
Напишите программу, которая заполняет массив из 10 элементов случайными числами на отрезке {-2,2} и находит произведение ненулевых элементов.
- 20.07.2018 01:47
- Информатика
- remove_red_eye 17906
- thumb_up 19
Ответы и объяснения 2
var a: array [1..n] of integer;
i,p: integer;
begin
for i:=1 to n do
a[i]:=random(-2,2);
writeln (a);
p:=1;
for i:=1 to n do
if a[i]0 then p:=p*a[i];
writeln (p)
end.
- 21.07.2018 04:37
- thumb_up 38
//Версия 3.3.5, сборка 1650
begin
var a:=ArrRandom(10,-2,2).Println.Where(x->x0);
write('произведение ненулевых элементов: ',a.Aggregate(Real(1),(a,b)->a*b));
end.
- 22.07.2018 03:24
- thumb_up 2
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.