Вопрос по информатике:
Напишите программу, которая переводит число (возможно, отрицательное), записанное в шестнадцатеричной системе, в десятичную систему. Входные данные Входная строка содержит шестнадцатеричную запись числа N ( 1 ≤ | N | < 10 9 ). Выходные данные Программа должна вывести десятичную запись этого числа.
- 12.12.2016 08:36
- Информатика
- remove_red_eye 12611
- thumb_up 45
Ответы и объяснения 1
using namespace std;
int main()
{
int N;
setlocale(LC_ALL, "Russian");
cin >> hex >> N;
cout << N << endl;
system("pause");
return 0;
}
Пример:
27A9A
162458
- 13.12.2016 09:13
- thumb_up 50
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.