Вопрос по информатике:
Составить программу вычисления среднего арифметического первых 50 чисел СРОЧНО МНОГО БАЛЛОВ
- 02.11.2017 01:47
- Информатика
- remove_red_eye 4071
- thumb_up 14
Ответы и объяснения 2
var i,s: integer;
begin
s:=0;
for i:=1 to 50 do s:=s+i;
writeln('s = ',s/50:4:1);
end.
Результат:
s = 25.5
Или так:
// Сумма первых n членов арифметической прогрессии S=(a1+an)/2*n
// Среднее арифметическое = S/n = (a1+an)/2
begin
writeln((1+50)/2:4:1);
end.
- 03.11.2017 06:34
- thumb_up 48
//Версия 3.3, сборка 1634
begin
//предполагаются первые 50 натуральных чисел
write('срзнач: ',range(1,50).Average);
end.
- 04.11.2017 17:01
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.