Вопрос по информатике:
Помогите пожалуйста написать программу по информатике:
Найти произведение положительных, сумму и количество отрицательных из 10 введенных целых чисел.
- 07.01.2018 05:47
- Информатика
- remove_red_eye 7711
- thumb_up 20
Ответы и объяснения 1
var a,k,s,pr,i:integer;mas:array [0..10] of integer;
begin
pr:=1;
for i:=1 to 10 do
readln(mas[i]);
for i:=1 to 10 do begin
if mas[i]>0 then
pr:=pr*mas[i]
else s:=s+mas[i];
end;
for i:=1 to 10 do
begin
if mas[i]<0 then k:=k+1;
end;
writeln('Произведение=',pr);
writeln('Сумма=',s);
writeln('Количество=',k)
end.
- 08.01.2018 11:41
- thumb_up 9
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.