Вопрос по информатике:
Написать программу, определяющую сумму/количество элементов массива, значение которых больше 1 и меньше 5.
На языке С++
- 04.03.2018 06:59
- Информатика
- remove_red_eye 6773
- thumb_up 48
Ответы и объяснения 1
#include
#include
using namespace std;
const size_t N = 10;
int main()
{
size_t sum = 0;
array a = { 1, 5, 9, 6, 3, 0, 1, 4, -2, 4 };
cout << "Count: ";
cout << accumulate(a.cbegin(), a.cend(), 0, [&sum](size_t count, const int
num) {
if (num > 1 && num < 5) {
++count;
sum += num;
}
return count;
});
cout << " Sum: " << sum << endl;
}
- 05.03.2018 14:32
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.