Вопрос по информатике:
Написать программу вычисления а10, где а - данное число если получившаяся программа требует более четырех умножений (использование функции sqr тоже считается умножением), то дать более экономное решение.
- 21.07.2018 22:17
- Информатика
- remove_red_eye 8221
- thumb_up 21
Ответы и объяснения 1
begin
readln(a);
a2:=a*a; // a^2
a4:=a2*a2; // a^4
a8:=a4*a4; // a^8
a10:=a8*a2; // a^10
writeln(a10);
end.
Пример:
2
1024
- 22.07.2018 22:54
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.