Вопрос по информатике:
Дан файл целых чисел с диапазоном значений от a до b. Определите, сколько раз встречается каждое значение в файле.
Язык С++.
- 26.08.2017 00:48
- Информатика
- remove_red_eye 4788
- thumb_up 23
Ответы и объяснения 2
#include
#include
using namespace std;
int main()
{
ifstream in;
ofstream out;
int a = 5, b = 15, c;
int k[b-a+1];
for (int i=0; i
while(in >> c)
{
k[c-a]++;
}
for (int i=0; i
in.close();
return 0;
}
Пример:
Содержимое файла f.txt:
7 10 15
8 7 7 10
Результат:
5 - 0
6 - 0
7 - 3
8 - 1
9 - 0
10 - 2
11 - 0
12 - 0
13 - 0
14 - 0
15 - 1
- 26.08.2017 05:13
- thumb_up 12
#include
#include
#include
#include
#include
#include
using namespace std;
mt19937 gen { random_device()() };
uniform_int_distribution uid(0, 100); //диапазон от 0..100
int main()
{
fstream f("F2.txt");
int a, b;
cin >> a >> b;
for (size_t i = a; i < b; ++i) {
f << uid(gen) << " ";
}
vector v;
map m;
int temp;
while ( !f.eof() ) {
f >> temp;
v.push_back(temp);
}
for (auto it = v.begin(); it != v.end(); ++it) {
m[*it]++;
}
for (const auto &i : m) {
cout << i.first << " = " << i.second << endl;
}
}
___________________
Пример:
55 13 51 55 55 21 38 59 62 20 62 10 9 55 28 60 28 24 95 7
7 = 1
9 = 1
10 = 1
13 = 1
20 = 1
21 = 1
24 = 1
28 = 2
38 = 1
51 = 1
55 = 4
59 = 1
60 = 1
62 = 2
95 = 1
- 27.08.2017 07:36
- thumb_up 11
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.