Вопрос по информатике:
На с++
Напишите программу, которая находит в массиве количество элементов, равных заданному значению X .
Входные данные
Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. В третьей строке записано число X . Гарантируется, что 0 < N ≤ 10000 .
Выходные данные
Программа должна вывести одно числа – количество элементов массива, равных X .
Примеры
входные данные
6
1 2 3 2 3 3
2
выходные данные
2
- 05.04.2016 03:39
- Информатика
- remove_red_eye 731
- thumb_up 44
Ответы и объяснения 1
#include
#include
#include
using namespace std;
int main()
{
size_t N, num;
cin >> N >> num;
vector a(N);
for (size_t i = 0; i < N; ++i)
cin >> a[i];
cout << count(a.begin(), a.end(), num);
}
- 06.04.2016 21:02
- thumb_up 15
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.