Вопрос по информатике:
Цикл с предусловием
Составить программу нахождения частного q и остатка от деления r целого числа х на целое число у, не используя операцию деления.
- 08.11.2015 03:32
- Информатика
- remove_red_eye 10795
- thumb_up 37
Ответы и объяснения 1
Var
x, y, q, r: integer;
begin
read(x,y);
r := x;
q := 0;
while r >= y do
begin
r := r - y;
q := q + 1
end;
write(q,' ',r)
end.
- 09.11.2015 03:36
- thumb_up 13
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.