Вопрос по информатике:
Дано целое число. Определить, сколько разрядов оно содержит
Вывести на экран 1, если число однозначное, вывести на экран 2, если число двузначное, вывести на экран 3, если число трехзначное.
Входные данные:Во входном потоке одно целое число, которое не превосходит значение 1000.
Выходные данные:Во входном потоке вывести 1 или 2 или 3
СРОЧНО
- 03.05.2017 14:46
- Информатика
- remove_red_eye 12095
- thumb_up 35
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var (n,k):=(ReadInteger,0);
while n>0 do (n,k):=(n div 10,k+1);
Writeln(k)
end.
- 04.05.2017 04:19
- thumb_up 43
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.