Вопрос по информатике:
Нужно написать программу на с++
мы вводим массив из букв, а программа должна их отсортировать по алфавиту
- 08.11.2016 18:10
- Информатика
- remove_red_eye 5248
- thumb_up 36
Ответы и объяснения 1
#include
using namespace std;
int main()
{
string S;
cin >> S;
int Mass[52];
for (int i = 0; i < 52; i++)
{
Mass[i] = 0;
}
for (int i = 0; i < S.length(); i++)
{
char c = S[i];
if (c >= 'a'&&c <= 'z')
{
Mass[(int)(c-'a')*2]++;
} else if (c >= 'A'&&c <= 'Z'){
Mass[(int)(c-'A')*2+1]++;
}
}
for (int i = 0; i < 52; i++)
{
for (int j = 0; j < Mass[i]; j++)
{
cout << (i % 2 == 0?(char)(i/2+'a'):(char)(i/2+'A'));
}
}
return 0;
}
Пример работы программы:
LKDKjgkjsdlfvkhnOLHDSKLJNFLjghlJNKSgbakjbjkHVLJhfvkjHVKJAyfjHLIhaLIUYGFLAkjbhdilAUGXIKJASILFYHGklajfbhliGFLKjblkJBDFIgiksjbnfowshKLJH
aaaAAAAbbbbbbBddDDDfffffFFFFFggggGGGGhhhhhhhHHHHHHiiiIIIIIjjjjjjjjjjjJJJJJJJkkkkkkkkkKKKKKKKKllllllLLLLLLLLLLLnnNNoOsssSSSUUvvVVwXyYY
- 09.11.2016 06:52
- thumb_up 43
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.